Applet Run Delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 02, 2018 - 18:38 PST
Investigating
We're experiencing an elevated level of Applet run errors and are currently looking into the issue.
Posted 4 months ago. Feb 02, 2018 - 13:24 PST