Activity Log Delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 6 months ago. Nov 27, 2017 - 15:24 PST
Identified
We're experiencing an elevated level of delays in Activity Logs and are working to resolve.
Posted 6 months ago. Nov 27, 2017 - 15:04 PST