Applet run delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 4 months ago. Jan 04, 2018 - 19:18 PST
Investigating
Some applet runs are delayed, we are currently working on the issue.
Posted 4 months ago. Jan 04, 2018 - 16:49 PST