The Twitter service is currently paused
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted Oct 13, 2021 - 12:04 PDT
Investigating
The Twitter service is paused while it is being updated. All Applets using these services will resume once the technical difficulties are resolved.
Posted Oct 13, 2021 - 11:40 PDT