Notification delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 8 months ago. Mar 23, 2018 - 13:56 PDT
Investigating
Applet push notifications are delayed
Posted 8 months ago. Mar 23, 2018 - 10:29 PDT