The Twitter service is currently paused
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted Apr 05, 2023 - 05:50 PDT
Investigating
Paused services may be experiencing technical difficulties. All Applets using these services will resume once the technical difficulties are resolved.
Posted Apr 03, 2023 - 10:44 PDT