Degraded performance for Twitter's (X) trigger - New tweet by a specific user

Incident Report for IFTTT

Resolved

This incident has been resolved.
Posted Sep 27, 2023 - 12:05 PDT

Investigating

We're investigating reports of the "New tweet by a specific user" trigger causing problems with some Applets.
Posted Aug 29, 2023 - 08:16 PDT
This incident affected: Applet performance.