IFTTT.com is currently unreachable
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 27 days ago. Aug 28, 2018 - 14:03 PDT
Investigating
We are currently investigating this issue.
Posted 27 days ago. Aug 28, 2018 - 13:51 PDT
This incident affected: IFTTT.com.