The App Store service is currently paused
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 05, 2018 - 15:31 PDT
Investigating
We are currently investigating this issue.
Posted 2 months ago. Jun 06, 2018 - 16:47 PDT
This incident affected: Applet performance.