Applet Run Delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 6 months ago. Nov 17, 2017 - 09:30 PST
Monitoring
We're experiencing an elevated level of Applet run errors and are currently looking into the issue.
Posted 6 months ago. Nov 16, 2017 - 18:16 PST