The Finance service is currently paused
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted Dec 21, 2020 - 16:10 PST
Identified
The API used to power the finance service is under maintenance. All Applets using these services will resume once the technical difficulties are resolved.
Posted Dec 17, 2020 - 16:48 PST