Notification Action Run Delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted Sep 18, 2020 - 19:14 PDT
Identified
We're experiencing an elevated level of Notification run delays and are currently looking into the issue.
Posted Sep 18, 2020 - 18:25 PDT