The Email Digest service is currently paused
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 11, 2018 - 09:42 PDT
Investigating
Paused services may be experiencing technical difficulties. All Applets using these services will resume once the technical difficulties are resolved.
Posted 4 months ago. Mar 10, 2018 - 23:22 PST