Issue that affected Applet runs

Incident Report for IFTTT

Resolved

Between March 3 at 8:00 PM UTC and March 4 at 4:30 AM UTC, some Applets may have run late or not triggered. The issue has been resolved, and Applets should now be functioning as expected. We apologize for any inconvenience and appreciate your patience. More details about this incident can be viewed here
Posted Mar 04, 2025 - 15:44 PST