The Domino’s service is currently paused
Incident Report for IFTTT
Resolved
This incident has been resolved
Posted May 20, 2020 - 14:50 PDT
Identified
Paused services may be experiencing technical difficulties. All Applets using these services will resume once the technical difficulties are resolved.
Posted May 07, 2020 - 14:42 PDT