The American Psychological Association service is currently paused
Incident Report for IFTTT
This service requires maintenance before it will be able to reliably function on IFTTT. We don't have an ETA for when this will be completed, but we will post updates here when they become available.
Posted 14 days ago. Mar 06, 2018 - 15:35 PST
Paused services may be experiencing technical difficulties. All Applets using these services will resume once the technical difficulties are resolved.
Posted 5 months ago. Nov 02, 2017 - 11:51 PDT