Images are not rendering on ifttt.com
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted Apr 10, 2020 - 16:55 PDT
Identified
We identified the issue and working on resolving it.
Posted Apr 10, 2020 - 12:36 PDT
This incident affected: IFTTT.com.