Issues Loading IFTTT.com
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 23 days ago. Oct 24, 2018 - 11:52 PDT
Investigating
We're experiencing issues loading ifttt.com and are currently looking into the issue.
Posted 23 days ago. Oct 24, 2018 - 11:51 PDT