The Bureau of Economic Analysis service is currently paused
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 28, 2018 - 10:15 PDT
Identified
Paused services may be experiencing technical difficulties. All Applets using these services will resume once the technical difficulties are resolved.
Posted 3 months ago. Aug 15, 2018 - 11:33 PDT
This incident affected: Applet performance.