Authorizing new connections to Instagram is currently not possible on the IFTTT mobile apps
Incident Report for IFTTT
Resolved
This issue is now resolved and you should be able to connect to Instagram on the mobile apps without problems.
Posted 3 months ago. Mar 12, 2018 - 10:49 PDT
Identified
There is currently an issue preventing users from making new connections to the Instagram service on the mobile apps. While this is being fixed, please connect to Instagram via IFTTT.com on a laptop or desktop. If you already have connected to Instagram, you shouldn't experience any problems.
Posted 3 months ago. Mar 06, 2018 - 15:18 PST