Google Glass service down
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted Aug 03, 2020 - 11:02 PDT
Investigating
We are currently investigating this issue.
Posted Mar 03, 2020 - 15:18 PST