Issues Loading IFTTT.com
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted Sep 01, 2021 - 22:25 PDT
Investigating
We're experiencing issues across IFTTT.com, the IFTTT Platform, and the IFTTT mobile apps and we are currently looking into the issue.
Posted Sep 01, 2021 - 22:20 PDT
This incident affected: IFTTT.com and IFTTT mobile apps.