Applet Run Delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted about 2 months ago. Mar 29, 2018 - 16:16 PDT
Investigating
Applet runs are currently delayed
Posted about 2 months ago. Mar 29, 2018 - 08:25 PDT