Email Action Run Delays
Incident Report for IFTTT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 18, 2020 - 11:01 PDT
Identified
We're experiencing an elevated level of Email action run delays and are currently looking into the issue.
Posted Sep 18, 2020 - 09:54 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 17, 2020 - 18:43 PDT
Investigating
We're experiencing an elevated level of Email action run delays and are currently looking into the issue.
Posted Sep 17, 2020 - 18:02 PDT