Issues Loading IFTTT.com, the IFTTT Platform, and the IFTTT mobile apps
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted Sep 28, 2020 - 19:36 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 28, 2020 - 16:43 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 28, 2020 - 16:37 PDT
Identified
We're experiencing issues across IFTTT.com, the IFTTT Platform, and the IFTTT mobile apps. Cause has been identified as relating to expired SSL certificates and we are in the process of updating them.
Posted Sep 28, 2020 - 15:15 PDT
This incident affected: IFTTT.com and IFTTT mobile apps.