Issues Loading IFTTT.com and the IFTTT mobile apps

Incident Report for IFTTT

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 00:08 PDT

Monitoring

We are seeing improvements in the responsiveness of our website and the mobile apps. We will continue to monitor service health until we can confirm that all issues have been resolved.
Posted Oct 20, 2025 - 14:24 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 09:43 PDT

Investigating

We're experiencing issues across IFTTT.com and the IFTTT mobile apps. We are currently looking into the issue.
Posted Oct 20, 2025 - 09:15 PDT
This incident affected: IFTTT.com and IFTTT mobile apps.