Issue affecting new connections to the Twitter service

Incident Report for IFTTT

Resolved

This incident has been resolved.
Posted May 23, 2025 - 11:51 PDT

Investigating

We’re currently experiencing an outage that prevents new connections to the Twitter service. Existing Twitter Applets and the creation of new Applets are not affected.

More details are available here: https://docs.x.com/status
Posted May 22, 2025 - 14:33 PDT