Issues with the Email service on IFTTT
Incident Report for IFTTT
Resolved
We identified a configuration issue with our email provider and the Email service has now been fixed. Thank you for your patience.
Posted May 18, 2020 - 09:21 PDT
Investigating
We are currently looking into an issue with the Email service. Thank you for your patience while we investigate.
Posted May 18, 2020 - 06:44 PDT
This incident affected: Applet performance.