The Google Contacts service is currently paused for maintenance
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted May 31, 2021 - 13:51 PDT
Identified
Google Contacts is paused for maintenance.
Posted May 27, 2021 - 14:35 PDT