The Seagate Personal Cloud service is currently paused
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted Jul 08, 2020 - 10:34 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 19, 2019 - 13:20 PDT
Investigating
Paused services may be experiencing technical difficulties. All Applets using these services will resume once the technical difficulties are resolved.
Posted Sep 09, 2019 - 09:20 PDT