Applet Run Delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 06, 2018 - 21:01 PST
Investigating
All applet runs are currently delayed
Posted 7 months ago. Mar 06, 2018 - 16:13 PST