The App Store service is currently paused
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 10 days ago. Sep 14, 2018 - 09:51 PDT
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Aug 14, 2018 - 11:43 PDT
This incident affected: Applet performance.