Issues Loading IFTTT.com
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted Mar 16, 2021 - 14:44 PDT
Investigating
We're experiencing issues across IFTTT.com, the IFTTT Platform, and the IFTTT mobile apps and we are currently looking into the issue.
Posted Mar 16, 2021 - 14:43 PDT
This incident affected: IFTTT.com and IFTTT mobile apps.