Email Digest delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 8 months ago. Mar 07, 2018 - 15:17 PST
Identified
Some email digest applets are delayed in sending
Posted 9 months ago. Mar 06, 2018 - 08:49 PST