Emails are currently delayed
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 02, 2018 - 10:45 PST
Identified
Emails sent using the Email service are currently experiencing a delay in being sent
Posted 4 months ago. Feb 02, 2018 - 09:16 PST