The Trello service is currently paused
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 31, 2017 - 09:06 PDT
Investigating
Paused services may be experiencing technical difficulties. All Applets using these services will resume once the technical difficulties are resolved.
Posted 4 months ago. Jul 31, 2017 - 08:52 PDT