Delayed Recipe runs

Incident Report for IFTTT

Resolved

We have resolved the issue and Recipes should be working as expected.
Posted Sep 20, 2015 - 08:27 PDT

Identified

We have identified an issue with our service provider. We will continue to provide updates as more information becomes available.
Posted Sep 20, 2015 - 07:30 PDT

Investigating

We are currently investigating this issue.
Posted Sep 20, 2015 - 03:40 PDT