The RescueTime service is currently paused
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 10 months ago. Feb 11, 2017 - 14:01 PST
Investigating
Paused services may be experiencing technical difficulties. All Applets using these services will resume once the technical difficulties are resolved.
Posted 10 months ago. Feb 11, 2017 - 00:17 PST