Issues Loading IFTTT.com
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 21 days ago. Oct 30, 2017 - 14:44 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 21 days ago. Oct 30, 2017 - 14:32 PDT
Investigating
We're experiencing issues loading ifttt.com and are currently looking into the issue.
Posted 21 days ago. Oct 30, 2017 - 14:19 PDT