Applet run delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 19 days ago. Oct 02, 2017 - 12:34 PDT
Identified
Some applets are running delayed, we are actively working on getting everything back to full speed.
Posted 19 days ago. Oct 02, 2017 - 11:34 PDT