Issues Loading IFTTT.com
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 16 days ago. Nov 27, 2017 - 14:11 PST
Investigating
We're experiencing issues loading ifttt.com and are currently looking into the issue.
Posted 16 days ago. Nov 27, 2017 - 13:40 PST