Applet Run Delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 8 months ago. Apr 26, 2017 - 15:13 PDT
Investigating
We're experiencing an elevated level of Applet run errors and are currently looking into the issue.
Posted 8 months ago. Apr 26, 2017 - 15:00 PDT