Intermittent Issues Loading IFTTT.com
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 16 days ago. Nov 27, 2017 - 15:31 PST
Identified
We're experiencing intermittent issues loading ifttt.com and are currently resolving the issue.
Posted 16 days ago. Nov 27, 2017 - 14:26 PST