The Equal Rights Advocates service is currently paused
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 18, 2017 - 09:52 PDT
Investigating
Paused services may be experiencing technical difficulties. All Applets using these services will resume once the technical difficulties are resolved.
Posted 3 months ago. Sep 16, 2017 - 20:30 PDT