Applet Run Delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted Sep 14, 2017 - 13:24 PDT
Investigating
We're experiencing an elevated level of Applet run errors and are currently looking into the issue.
Posted Sep 14, 2017 - 12:01 PDT