The Muzik service is currently paused
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 06, 2017 - 14:31 PDT
Identified
Paused services may be experiencing technical difficulties. All Applets using these services will resume once the technical difficulties are resolved.
Posted 3 months ago. Sep 25, 2017 - 10:46 PDT