Email Digests are delayed
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 26 days ago. Jan 27, 2018 - 18:02 PST
Investigating
Some Email Digests are experiencing delivery delays
Posted 27 days ago. Jan 26, 2018 - 10:30 PST