IFTTT app notifications are delayed
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted about 1 month ago. Oct 17, 2017 - 11:48 PDT
Monitoring
Some notifications of activity from IFTTT may be temporarily delayed
Posted about 1 month ago. Oct 17, 2017 - 10:02 PDT