IFTTT is temporarily unavailable
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 13 days ago. May 12, 2017 - 14:27 PDT
Investigating
We are currently investigating this issue.
Posted 13 days ago. May 12, 2017 - 13:49 PDT