Notifications delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 24 days ago. Oct 26, 2017 - 23:42 PDT
Identified
We're experiencing an elevated level of delays in Notifications and are currently looking into the issue.
Posted 24 days ago. Oct 26, 2017 - 20:51 PDT